Invio email

max1974

Utente Attivo
7 Mar 2013
107
0
16
scusate sto inviando le mail attraverso php
Codice:
$adminEmail = '[email protected]';
$mail_headers = "From:".$adminEmail."\r\n";
$mail_headers .= "X-Mailer: PHP/" . phpversion();
$mail_headers .= "MIME-Version: 1.0\r\n";
$mail_headers .= "Content-type: text/html; charset=iso-8859-1";
$bodyMailUser = "Ciao";
$Usermessage = '<html><head></head><body><div style="background-color:#fff;">' . $bodyMailUser . '</div></body></html>';
mail('[email protected]', 'Messaggio', $Usermessage, $mail_headers);
la mia mail arriva, ma alcuni server la bloccano credo che il motivo sia perche come indirizzo del mittente mi compare
u1755***[email protected]-hosting.eu <u1755***[email protected]-hosting.eu> per conto di [email protected] <[email protected]>
potete aiutarmi please ???
tutto quello che sta davanti credo provenga dal dominio....cosa dovrei controllare ?????
 

max1974

Utente Attivo
7 Mar 2013
107
0
16
Manca roba manca....
Metti il DMARC con il domainkey!
Scusa ho trovato e stavo seguendo questa guida (http://php-dkim.sourceforge.net/), perche non so proprio da dove cominciare....
ho contattato il mio hosting e mi hanno dato queste chiavi che vedi in foto allegata (scusa se ho coperto ma non sapevo se poteva essere pubblico) ora ho provato a configurare come nella guida, ma li dice che :
1° Mi dice di generare la chiave privata RSA
2° Mi chiede di generare la chiave pubblica RSA
sono forse qualcuna di queste o non ci sto capendo una mazza ???
image.png
 

max1974

Utente Attivo
7 Mar 2013
107
0
16
dovrei aver fatto un passo avanti seguendo la guida (http://php-dkim.sourceforge.net/) , ho scaricato il pacchetto integrato i file php, configurando il file dkim-cfg.php e poi alla fine ho lanciato il file dkim-test.php, e proprio quando lancio quest'ultimo ricevo questo messaggio dove ora sono bloccato:

Excellent, you have DKIM keys You should add the following DNS RR: admin._domainkey IN TXT "v=DKIM1\; k=rsa\; g=*\; s=email\; h=sha1\; t=s\; p=ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQCJ+....................ektCdDksajCBXF\;"

ho già inserito quello che chiede nel mio dominio (vedi foto allegata) , ma nonastante questo ho sempre solito messaggio, cosa sto sbagliando ???
 

Allegati

erwin

Nuovo Utente
16 Set 2019
7
0
1
Innanzitutto vai qui: https://mxtoolbox.com/
inserisci il tuo dominio fai uno screenshot e posta, poi vediamo cosa c'è che non va. Per quanto ne so potresti anche essere in blacklist e quindi gli altri server rifiutano. Ma è presto anticipare problemi/soluzioni. Iniziare a postare il risultato poi valutiamo il da fare.
 

max1974

Utente Attivo
7 Mar 2013
107
0
16
Innanzitutto vai qui: https://mxtoolbox.com/
inserisci il tuo dominio fai uno screenshot e posta, poi vediamo cosa c'è che non va. Per quanto ne so potresti anche essere in blacklist e quindi gli altri server rifiutano. Ma è presto anticipare problemi/soluzioni. Iniziare a postare il risultato poi valutiamo il da fare.
grazie innanzitutto per la risposta spero sia cio che mi chiedevi:
 

Allegati

erwin

Nuovo Utente
16 Set 2019
7
0
1
dunque, ho fatto un check. Non sei in black e neanche il server smtp che ti supporta l'invio. Ovvio non hai il DMARC e questo potrebbe far considerare la tua email come non trusted. Bisogna capire a chi invii e chiedere loro. Però è tutto un lavoraccio inutile se poi hai come dominio "myapptest.site". Voglio dire stai facendo delle prove?
 

max1974

Utente Attivo
7 Mar 2013
107
0
16
dunque, ho fatto un check. Non sei in black e neanche il server smtp che ti supporta l'invio. Ovvio non hai il DMARC e questo potrebbe far considerare la tua email come non trusted. Bisogna capire a chi invii e chiedere loro. Però è tutto un lavoraccio inutile se poi hai come dominio "myapptest.site". Voglio dire stai facendo delle prove?
non è un dominio di prova se è questo che vuoi sapere...