Problema con menù a tendina

Bloodkurenai

Nuovo Utente
11 Gen 2013
5
0
0
Ciao ragazzi avrei bisogno del vostro aiuto perché io non so più che pesci prendere :crying:
Ho un classico menù a tendina orizzontale (per intenderci come questo) solo che non ne capisco il motivo il sottomenù è bloccato tutto a sinistra, anche andando sopra l'ultima voce del menù, il sottomenù compare all'inizio dove c'è la prima voce. Non riesco a capire come mai e non so più che fare :crying: una mano per favore? :crying:
Il codice:
HTML:
<ul class="menu">
     <li><a href="" class="a_menu" title="">Home</a></li>
     <li><a href="" class="a_menu" title="">Home</a>
     <ul class="sottomenu">
     <li><a href="" class="a_sottomenu" title="">Prova</a></li>
     <li><a href="" class="a_sottomenu" title="">Prova</a></li>
      <li><a href="" class="a_sottomenu" title="">Prova</a></li>
     </ul>
     </li>
     <li><a href="" class="a_menu" title="">Home</a></li>
    </ul>
CSS:
Codice:
.menu {
background-color: #F48529;
-moz-border-radius: 0px 0px 20px 0px;
-webkit-border-radius: 0px 0px 20px 0px;
width: auto;
display: inline;
padding-bottom: 0.3em;
border-bottom: groove red 3px;
border-right: groove red 3px;  
}
.menu li {
display: inline;
padding-right: 2em;
}
a.a_menu {
text-decoration: none;
}
.sottomenu {
display: none;
position: absolute;
background-color: #F48529;
-moz-border-radius: 0px 0px 20px 0px;
-webkit-border-radius: 0px 0px 20px 0px;
padding-bottom: 0.3em;
border-bottom: groove red 3px;
border-right: groove red 3px;
top:1.75em;
z-index: 1;
}
.menu li:hover ul.sottomenu {
display: block;
position: absolute;
z-index: 1;
}
.menu li:hover ul li {
position: relative;
display: block;
}
.sottomenu li a {
	text-decoration: none;
}
Grazie in anticipo >w<
 

Nefyt

Utente Attivo
17 Apr 2012
1.102
0
0
Ciao, prova modificando il css cosi
Codice:
.menu {
background-color: #F48529;
-moz-border-radius: 0px 0px 20px 0px;
-webkit-border-radius: 0px 0px 20px 0px;
width: auto;
display: inline;
padding-bottom: 0.3em;
border-bottom: groove red 3px;
border-right: groove red 3px;  
}
.menu li{
display: inline;
position:relative;
padding-right:3em;
}

a.a_menu {
text-decoration: none;
}
.sottomenu {
display: none;
position: absolute;
background-color: #F48529;
-moz-border-radius: 0px 20px 0px 20px;
-webkit-border-radius: 0px 20px 20px 20px;
padding-bottom: 0.3em;
border-bottom: groove red 3px;
border-right: groove red 3px;
z-index: 1;
top:1.5em;
left:-2.5em;
}
.menu li:hover ul.sottomenu{
display: block;
position: absolute;
z-index: 1;
}
.menu li:hover ul li {
position: relative;
display: block;
}
.sottomenu li a {
	text-decoration: none;
}
Notte
 

Bloodkurenai

Nuovo Utente
11 Gen 2013
5
0
0
Allora forse ho capito dove sta il problema.
Con questo codice:
Codice:
.menu {
background-color: #F48529;
-moz-border-radius: 0px 0px 20px 0px;
-webkit-border-radius: 0px 0px 20px 0px;
width: auto;
/**/display: inline;
padding-bottom: 0.3em;
border-bottom: groove red 3px;
border-right: groove red 3px;
/*display: block;*/
}
.menu li {
display: inline;
padding-right: 2em;*/
/*aggiunti*/
float: left;
position: relative;
}
a.a_menu {
text-decoration: none;
}
.sottomenu {
display: none;
position: absolute;
background-color: #F48529;
-moz-border-radius: 0px 0px 20px 0px;
-webkit-border-radius: 0px 0px 20px 0px;
padding-bottom: 0.3em;
border-bottom: groove red 3px;
border-right: groove red 3px;
top:1.75em;
z-index: 1;
}
.menu li:hover ul.sottomenu {
display: block;
position: absolute;
z-index: 1;
}
.menu li:hover ul li {
position: relative;
display: block;
}
.sottomenu li a {
	text-decoration: none;
}
Su chrome si vede correttamente, mentre mozzilla me lo blocca sempre a sinistra...mmmh qualche idea? :S
 

Bloodkurenai

Nuovo Utente
11 Gen 2013
5
0
0
No ok ho risolto XD c'era un errore di battitura (avevo lasciato un "*/"). Quindi adesso per funzionare funziona ma per qualche strano motivo mi è sparito lo sfondo dal menù principale, mi è toccato metterlo ai singoli elementi ma non è tanto normale O.ò
 
Discussioni simili
Autore Titolo Forum Risposte Data
P problema con tendina del menù, scompare sotto i contenuti HTML e CSS 7
L problema con menù css HTML e CSS 1
SilentMohai Problema di visualizzazione menù Javascript con InternetExplorer Javascript 0
P Problema con un menù a tendina PHP 7
G problema con menù e pulsanti flash Flash 0
T PROBLEMA CON SESSIONI PHP 3
T ALTRO PROBLEMA CON ARRAY PHP PHP 1
T PROBLEMA CON ARRAY PHP 8
L problema con query select PHP 2
R Problema query con ricerca id numerico PHP 2
F Problema con risposta PHP 0
S problema con recupero dati tabella mysql PHP 2
Z Problema con il mio tp-l i nk Reti LAN e Wireless 1
L Problema RAM con Tomcat 8 Apache 0
napuleone problema con sort e asort PHP 4
Z Problema con INT MySQL PHP 1
Z Problema database MySQL con XAMPP PHP 0
M Problema con controllo form in real time jQuery 6
Z Problema di sincronizzazione PAYPAL con PHP PHP 1
G Problema con Get page PHP 4
P Problema con require once PHP 6
P Problema con i package Java 1
A Problema login con Safari PHP 14
F INDESIGN: problema esportazione esecutivo per la stampa con foto B/N Webdesign e Grafica 1
S problema con css bootstrap3 HTML e CSS 4
M .load() problema con caricamenti dinamici di js Javascript 0
G Problema ------- con Query PHP 1
G Problema con Query PHP 1
T problema con select dinamica con jquery Javascript 0
S Problema con spazi bianchi HTML e CSS 5
A PROBLEMA: insert mysqli con dati Tagsinput Presentati al Forum 0
Tommy03 Problema con z-index HTML e CSS 3
M Problema inserimento parole con apostrofo nel db PHP 5
C Problema con dati meteo xml XML 1
S Problema con infrarossi videocamera IP Cam e Videosorveglianza 1
V Problema con librerie allegro5 c++ C/C++ 1
M Problema con php per calcolo costo percentuale PHP 7
S Problema con mysqli_num_rows PHP 18
grgfede Problema javascript con aruba Javascript 1
M Problema con visibility e radio button Javascript 2
Marti1! Problema con casella mail cancellata Posta Elettronica 3
L [PHP] Problema con Telegram PHP 1
tomorc [HTML] Problema con scroll bar (risolto) HTML e CSS 0
S Strano problema con i title su Google SEO e Posizionamento 3
P [ASP.Net] Problema ERR_INCOMPLETE_CHUNKED_ENCODING 206 (Partial Content) con Font ASP.NET 4
P [HTML] Problema ERR_INCOMPLETE_CHUNKED_ENCODING 206 (Partial Content) con Font HTML e CSS 1
N [Apache] problema con estensione php Apache 0
C [PHP] Problema con download file PHP 0
M [PHP] Problema con preg_match PHP 1
gandalf1959 [PHP] problema con l'utilizzo di Header PHP 3

Discussioni simili