[MS Access] Impossibile aprire una maschera da pulsante

ste80

Nuovo Utente
25 Feb 2012
38
0
6
40
Brescia
Buongiorno,
ho un problema per quanto riguarda la visualizzazione delle maschere e dei report.
Ho un DB in access 2016 nel quale ho un pulsante che, una volta cliccato, mi apre una maschera anagrafica.

Quando premo il tasto mi si apre la mia maschera ma se io faccio un aggiornamento, ad esempio se stringo la maschera, salvo e chiudo, quando riapro il DB e clicco su quel pulsante non mi apre più la maschera... nessun errore solo non apre la maschera, per poterla aprire nuovamente devo andare in visualizzazione struttura della maschera, salvare anche senza aver modificato nulla e chiudere, poi cliccare ancora sul pulsante legato alla maschera e si riapre fino a che non salvo nuovamente un parametro (esempio stringo la maschera e salvo) a quel punto il bottone non mi apre più la maschera. Devo fare ancora il giro in visualizzazione struttura, salvare e dal quel momento il bottone mi fa aprire nuovamente la maschera.
Mi succede con report e maschere, non capisco perché e non trovo da nessuna parte una soluzione.
Grazie
Stefano
 

CarlettoFed

Utente Attivo
17 Lug 2017
82
1
8
67
Forse se alleghi il file si riesce a darti una soluzione, in quanto se non si vede che cosa accade realmente è difficile risponderti
 

ste80

Nuovo Utente
25 Feb 2012
38
0
6
40
Brescia
Ciao e grazie,
sono riuscito a risolvere la situazione da solo, il problema era che la maschera veniva aperta ma non era visibile, mi è bastato impostare l'attributo "allineamento al centro automatico" e adesso funziona.