Problemi nell'uso dell'oggetto MYSQLI

konqueror

Nuovo Utente
20 Mag 2011
7
0
0
Salve!
Sto cominciando ad usare l'oggetto MYSQLI, questa è la pagina di riferimento:
http://php.net/manual/en/mysqli.multi-query.php

Il mio codice è identico a quello proposto dal manuale ufficiale, quindi c'è poco da sbagliare.
Il database esiste poichè l'ho creato in precedenza ma è sempre vuoto nonostante il lancio dello script:
PHP:
<?php
$database = "prova";
$user = "admin";
$pass = "admin";
$link = mysqli_connect("localhost", "root", "CICCIO", "prova");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}


$query = "USE '$database';";
$query .=  "CREATE TABLE IF NOT EXISTS commenti(
idcommento INT NOT NULL AUTO_INCREMENT PRIMARY KEY,
id INT NOT NULL,
user VARCHAR(55) NOT NULL,
email VARCHAR(55) NOT NULL,
data DATE NOT NULL,
commento TEXT NOT NULL,
approvato TINYINT(1) NOT NULL
);";
$query .=  "CREATE TABLE IF NOT EXISTS News (
id INT NOT NULL AUTO_INCREMENT PRIMARY KEY,
testonews TEXT NOT NULL,
titolonews TINYTEXT NOT NULL,
datanews DATE NOT NULL,
autorenews VARCHAR(50) NOT NULL
);";
$query .= "ALTER TABLE commenti
ADD FOREIGN KEY (id) REFERENCES News(id);";
$query .=  "CREATE TABLE IF NOT EXISTS login(
user VARCHAR(50) NOT NULL,
pass VARCHAR(100) NOT NULL
);";
$query .= "INSERT INTO login (user,pass) VALUES ('$user', '$pass')";


/* execute multi query */
[B]if (mysqli_multi_query($link, $query))[/B] {
    do {
        /* store first result set */
        if ($result = mysqli_store_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
} {
	echo "fail";
}

/* close connection */
mysqli_close($link);
?>

Ho fatto il debug ed ho scoperto che l'istruzione
PHP:
if (mysqli_multi_query($link, $query))
mi da FALSE ergo la query non viene eseguita.
Sto cominciando a considerare l'idea che php non mi faccia fare determinate query del tipo CREATE TABLE o cose affini.
Forse per questo genere di funzioni ci vuole altro?
grazie
 

Eliox

Utente Attivo
25 Feb 2005
4.390
3
0
E' da escludere che PHP non permetta l'utilizzo di CREATE TABLE, qualche volta prò sono presenti dei limiti dovuti alla configurazione del proprio hosting o ai privilegi del proprio account.
 
Discussioni simili
Autore Titolo Forum Risposte Data
P Problemi nell'update aggiorna un unico utente anche se entro come pallo e non pinco PHP 6
V Usa la libreria "phpgraphlib.php" problemi nell'includere altri file PHP 2
catellostefano Problemi nell' instalalzione di vmware Linux e Software 0
T Problemi nell'inserire frame con dreamweaver mx HTML e CSS 1
F Problemi visualizzazione mappa Android studio Sviluppo app per Android 0
S Problemi Javascript + Aruba Javascript 2
A Problemi con move_uploaded_file PHP 7
M Problemi con la stampa dei valori in php PHP 1
L Problemi con il login PHP 2
L Problemi form Pagina php HTML e CSS 3
R Tutto su utf-8 ma ancora problemi con i caratteri speciali in mysql MySQL 1
Z problemi con foreach insert into PHP 10
B javascript per problemi con pdf e Safari Javascript 0
N Problemi kit videosorveglianza IP Cam e Videosorveglianza 0
M Problemi con creazione maschere Presentati al Forum 1
M Problemi con query a più tabelle PHP 3
R Problemi anomalo insermento in db PHP 9
S Problemi delle funzioni eliminate con PHP e MySQL PHP 4
S Problemi di un principiante PHP 3
M Problemi con blog Grav CMS (Content Management System) 0
F Problemi di visualizzazione di un sito su più browser WordPress 0
S Problemi di visualizzazione form contatti sito web HTML e CSS 2
S incoerenza di stampa. problemi con il magenta Photoshop 3
A problemi con paypall Java 1
A Problemi di accesso da remoto a Ipcam IP Cam e Videosorveglianza 6
michele81 [WordPress] problemi plug meteo api key WordPress 4
E Problemi in registrazione telecamere Dahua IP Cam e Videosorveglianza 6
felino [Windows 8.1] Problemi con connessione WiFi Windows e Software 0
M [PHP] Problemi su inserimento array nel db PHP 7
E [PHP] problemi nuova riga con fwrite su piattaforma android PHP 5
M [PHP] Problemi di salvataggio su campo calcolato PHP 0
O [HTML] problemi con la regola "background-attachment: fixed" in EDGE HTML e CSS 0
M [PHP] Problemi con query unione PHP 11
M [PHP] Problemi con select PHP 6
Spown [WordPress] Problemi visualizzazione su più browser + voci menu in movimento WordPress 1
ANDREA20 [HTML] problemi con il footer HTML e CSS 1
D [MS Access] problemi con inserimento campo in una maschera MS Access 6
M [PHP] Problemi con il riconoscimento login. PHP 21
A [WordPress] problemi con xampp WordPress 2
M Problemi con database Apache/2.4.37 (Win32) OpenSSL/1.1.1a PHP/7.3.1 PHP 6
P Problemi comunicazioni Comunicazioni dallo Staff 8
G I problemi non vengono solo per nuocere Presentati al Forum 0
A Problemi Wi-Fi Fastweb Reti LAN e Wireless 4
C [WordPress] Url vulnerability e problemi sito da mobile WordPress 0
S [PHP] problemi con le sessioni PHP 3
B Problemi accesso Instagram Smartphone e tablet 1
T [PHP] problemi con il browser PHP 0
M [Flash] Problemi conversione formato swf Flash 20
Andrea_Ventura [HTML] Problemi con effetto hover HTML e CSS 5
spider81man [PHP] Problemi cancellazione dato su DB [RISOLTO] PHP 1

Discussioni simili