Problemi di output

antcru

Nuovo Utente
19 Mar 2008
3
0
0
Ciao a tutti,
ho un problema che non riesco a capire.
un semplice script ASP richiamato da un'altra semplice pagina html non mi mostra l'output che gli passo nelle text.
La cosa strana è che su alcuni PC funziona e su altri no.
Da cosa ouò dipendere?

P.s il browser è Internet Explorer, sia sui Pc dove funziona che su quelli dove non funziona.

Vi posto il codice.

Pagina HTML(di nome registrazione.html)

<html>
<head>
<title>Registrazione al servizio web</title>
</head>
<body bgcolor="#FFFF00">
<h3>Benvenuto! Attraverso questa pagina potrai registrare i tuoi dati!</h3>

<form method="post" action="iscrizione.asp">
<p>Nome: <input type="text" size=20 name="nome">
<p>Cognome: <input type="text" size=20 name="cognome">
<p>E-mail: <input type="text" size=20 name="email">
<p><input type="submit" value="Invia" size=20 name="b1">
<input type="reset" value="Cancella" size=20 name="c1">
</form>
</body>
</html>

Pagina ASP(di nome iscrizione.asp)

<%@ language = JScript %>
<%
var stringa1;
var stringa2;
var stringa3;
stringa1 = Request.Form ("nome");
stringa2 = Request.Form ("cognome");
stringa3 = Request.Form ("email");
%>
<html>
<body bgcolor=#ff00ff>
<h3>I dati che hai inserito sono: </h3><hr>
Cognome: <% Response.Write (stringa2); %><br>
Nome: <% Response.Write (stringa1); %><br>
E-mail: <% Response.Write (stringa3); %><br><hr>
</body>
</html>

Grazie
 

antcru

Nuovo Utente
19 Mar 2008
3
0
0
Provo su localhost.
Lo script so che funziona, non riesco a spiegarmi perchè su alcuni Pc funziona e su altri no!Su questi Pc(quelli dove non funziona) è come se non arrivasse nulla dalla pagina html
Mah!!
 

lukeonweb

Utente Attivo
5 Mar 2003
5.177
10
38
43
Napoli
www.lucaruggiero.it
Se lo provi su localhost può essere normale: magari su alcuni ci sono problemi di impostazioni di IIS o magari su altri lo provi attraverso 98/PWS che ha un diverso sistma di gestione del buffer.

Non spaccarti la testa su un problema inesistente e limitati a configurare bene un computer: il tuo!

Con l'esperienza e col tempo vedrai che localhost non lo userai nemmeno più e inizierai a lavorare direttamente online!
 

antcru

Nuovo Utente
19 Mar 2008
3
0
0
il problema è che proprio sul mio computer non funziona!:incazz2:
Cosa dovrei fare per configurarlo bene?
Per la cronaca, su tutti e due i computer c'è IIS, XP Pro, IE.

Grazie
 
Discussioni simili
Autore Titolo Forum Risposte Data
S Form, problemi di output Classic ASP 0
M Upload immagine con javascript problemi con FormData() Javascript 1
F Problemi visualizzazione mappa Android studio Sviluppo app per Android 0
S Problemi Javascript + Aruba Javascript 2
A Problemi con move_uploaded_file PHP 7
M Problemi con la stampa dei valori in php PHP 1
L Problemi con il login PHP 2
L Problemi form Pagina php HTML e CSS 3
R Tutto su utf-8 ma ancora problemi con i caratteri speciali in mysql MySQL 1
Z problemi con foreach insert into PHP 10
B javascript per problemi con pdf e Safari Javascript 0
N Problemi kit videosorveglianza IP Cam e Videosorveglianza 0
M Problemi con creazione maschere Presentati al Forum 1
M Problemi con query a più tabelle PHP 3
R Problemi anomalo insermento in db PHP 9
S Problemi delle funzioni eliminate con PHP e MySQL PHP 4
S Problemi di un principiante PHP 3
M Problemi con blog Grav CMS (Content Management System) 0
F Problemi di visualizzazione di un sito su più browser WordPress 0
S Problemi di visualizzazione form contatti sito web HTML e CSS 2
S incoerenza di stampa. problemi con il magenta Photoshop 3
A problemi con paypall Java 1
A Problemi di accesso da remoto a Ipcam IP Cam e Videosorveglianza 6
michele81 [WordPress] problemi plug meteo api key WordPress 4
E Problemi in registrazione telecamere Dahua IP Cam e Videosorveglianza 6
felino [Windows 8.1] Problemi con connessione WiFi Windows e Software 0
M [PHP] Problemi su inserimento array nel db PHP 7
E [PHP] problemi nuova riga con fwrite su piattaforma android PHP 5
M [PHP] Problemi di salvataggio su campo calcolato PHP 0
O [HTML] problemi con la regola "background-attachment: fixed" in EDGE HTML e CSS 0
M [PHP] Problemi con query unione PHP 11
M [PHP] Problemi con select PHP 6
Spown [WordPress] Problemi visualizzazione su più browser + voci menu in movimento WordPress 1
ANDREA20 [HTML] problemi con il footer HTML e CSS 1
D [MS Access] problemi con inserimento campo in una maschera MS Access 6
M [PHP] Problemi con il riconoscimento login. PHP 21
A [WordPress] problemi con xampp WordPress 2
M Problemi con database Apache/2.4.37 (Win32) OpenSSL/1.1.1a PHP/7.3.1 PHP 6
P Problemi comunicazioni Comunicazioni dallo Staff 8
G I problemi non vengono solo per nuocere Presentati al Forum 0
A Problemi Wi-Fi Fastweb Reti LAN e Wireless 4
C [WordPress] Url vulnerability e problemi sito da mobile WordPress 0
S [PHP] problemi con le sessioni PHP 3
B Problemi accesso Instagram Smartphone e tablet 1
T [PHP] problemi con il browser PHP 0
M [Flash] Problemi conversione formato swf Flash 20
Andrea_Ventura [HTML] Problemi con effetto hover HTML e CSS 5
spider81man [PHP] Problemi cancellazione dato su DB [RISOLTO] PHP 1
M [PHP] Problemi con login facebook PHP 0
Andrea_Ventura [HTML] Problemi con visualizzazione Navigation Bar HTML e CSS 10

Discussioni simili