Problema Tomcat+Python

codesurfer

Nuovo Utente
13 Feb 2008
16
3
0
Ciao a tutti,
ho un problema con la configurazione di Tomcat per l'esecuzione degli script Python.
Seguendo la miniguida del sito di Tomcat ho fatto le modifiche che dovrebbero abilitare il webserver ad eseguire i CGI ma ancora mi si presenta una pagina web completamente vuota e nessun errore nei log.

La mia configurazione è questa:

La cartella dove ho installato Tomcat è C:\Program Files\Tomcat 6.0
La cartella dove ho la webapp è: C:\Program Files\xampp\htdocs\test_jsp
La cartella dove ho lo script è C:\Program Files\xampp\htdocs\test_jsp\WEB-INF\cgi
La cartella dove ho installato Python è C:\Program Files\Python3.1

Nel file C:\Program Files\Tomcat 6.0\conf\web.xml ho inserito:
Codice:
       <servlet>
        <servlet-name>cgi</servlet-name>
        <servlet-class>org.apache.catalina.servlets.CGIServlet</servlet-class>
        <init-param>
          <param-name>debug</param-name>
          <param-value>0</param-value>
        </init-param>
        <init-param>
          <param-name>cgiPathPrefix</param-name>
          <param-value>WEB-INF/cgi</param-value>
        </init-param>
        <init-param>
            <param-name>executable</param-name>
            <param-value>C:\Program Files\Python3.1\pythonw.exe</param-value>
        </init-param>
        <init-param>
            <param-name>passShellEnvironment</param-name>
            <param-value>true</param-value>
        </init-param>
        <load-on-startup>5</load-on-startup>
    </servlet>

    <servlet-mapping>
        <servlet-name>cgi</servlet-name>
        <url-pattern>/cgi-bin/*</url-pattern>
    </servlet-mapping>

Nella cartella C:\Program Files\Tomcat 6.0\lib ho aggiunto il file servlets-cgi.jar.

Il test che ho fatto è il seguente:
Codice:
<jsp:include page="templates/header.html" />
<%@ taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core" %>
<%@ taglib prefix="sql" uri="http://java.sun.com/jsp/jstl/sql" %>
<%@ taglib prefix="x" uri="http://java.sun.com/jsp/jstl/xml" %>
<%@ page import="java.sql.*" %>
<%@ page import="java.util.Vector" %>
<%@ page import="java.awt.event.*" %>
<%@ page import="java.io.*" %>
<%@page import="java.util.Hashtable" %>
<%@page import="javax.naming.*" %>
<%@page import="javax.naming.ldap.*" %>
<%@page import="javax.naming.directory.*" %>

.....codice......

<iframe id="pyTest" name="pyTest" frameborder="0" scrolling="no" src="python.py" />

<jsp:include page="templates/footer.html" />

E lo script python è:
Codice:
#!C:\Program Files\Python3.1\pythonw.exe
print('Content-type: text/html')

print ("Hello World");

Commentando il codice aggiunto nel file web.xml la pagina si visualizza correttamente eccetto lo script python che viene stampato come testo invece che eseguito (quindi la parte JSP funziona).

Qualcuno ha qualche dritta per la configurazione di Tomcat?

Grazie in anticipo :D
 

codesurfer

Nuovo Utente
13 Feb 2008
16
3
0
Se potesse interessare a qualcuno ho trovato la configurazione funzionante:
-nel file web.xml in path_install_tomcat\conf scommentare il seguente codice (alcuni parametri li ho aggiunti manualmente):
Codice:
    <servlet>
        <servlet-name>cgi</servlet-name>
        <servlet-class>org.apache.catalina.servlets.CGIServlet</servlet-class>
        <init-param>
          <param-name>debug</param-name>
          <param-value>0</param-value>
        </init-param>
        <init-param>
          <param-name>cgiPathPrefix</param-name>
          <param-value>WEB-INF/cgi</param-value>
        </init-param>
        <init-param>
            <param-name>executable</param-name>
            <param-value>C:\Program Files\Python3.1\pythonw.exe</param-value>
        </init-param>
        <init-param>
            <param-name>passShellEnvironment</param-name>
            <param-value>true</param-value>
        </init-param>
        <load-on-startup>5</load-on-startup>
    </servlet>

-nello stesso file scommentare:
Codice:
    <servlet-mapping>
        <servlet-name>cgi</servlet-name>
        <url-pattern>/cgi-bin/*</url-pattern>
    </servlet-mapping>

-nel file path_webapp\META-INF\context-xml aggiungere all'element Context il parametro privileged="true".

-inserire gli script CGI nella cartella path_webapp\WEB-INF\cgi\ (o nella cartella specificata precedentemente <param-value>WEB-INF/cgi/</param-value>).

-da browser richiamare lo script con http://localhost/nome_webapp/cgi-bin/nome_script

-da altri file utilizzare normalmente il percorso relativo sostituendo WEB-INF/cgi/nome_script con cgi-bin/nome_script.
 
Discussioni simili
Autore Titolo Forum Risposte Data
F NetBeans problema creazione progetto Java Windows e Software 0
M Problema con Try Catch PHP 0
C problema seo + cerco esperto SEO e Posizionamento 1
Sergio Unia Problema con gli eventi del mouse su una data table: Javascript 2
T PROBLEMA CON SESSIONI PHP 3
A Problema, non so, di scale() o transform, oppure altro? HTML e CSS 0
T ALTRO PROBLEMA CON ARRAY PHP PHP 1
T PROBLEMA CON ARRAY PHP 8
L problema con query select PHP 2
R Problema query con ricerca id numerico PHP 2
F Problema con risposta PHP 0
S problema con recupero dati tabella mysql PHP 2
Z Problema con il mio tp-l i nk Reti LAN e Wireless 1
I PROBLEMA: Sostituzione sito XAMPP E-Commerce 0
T problema data 30/11/-1 PHP 0
L Problema RAM con Tomcat 8 Apache 0
napuleone problema con sort e asort PHP 4
Y Problema incolonnamento tabella PHP 7
S problema salvataggio immagini Photoshop 0
Z Problema con INT MySQL PHP 1
Z Problema database MySQL con XAMPP PHP 0
M Problema con controllo form in real time jQuery 6
D problema php mysql PHP 1
D problema php mysql PHP 1
M Problema Wi-Fi Linux Linux e Software 1
Z Problema di sincronizzazione PAYPAL con PHP PHP 1
Daniele_Carrara Problema Aperture Mailup Email Marketing 5
F PROBLEMA ACCESSO INSTAGRAM Discussioni Varie 2
R Problema connessione db PHP 7
M problema if PHP 2
G Problema con Get page PHP 4
N Problema passaggio variabili tra pagine PHP 4
P Problema con require once PHP 6
P Problema con i package Java 1
A Problema login con Safari PHP 14
F INDESIGN: problema esportazione esecutivo per la stampa con foto B/N Webdesign e Grafica 1
H problema carrello woocommerce PHP 2
S problema con css bootstrap3 HTML e CSS 4
M .load() problema con caricamenti dinamici di js Javascript 0
M Problema su query JOIN in tre tabelle PHP 0
S Problema esportazione tabelle Mysql in Excel PHP 0
G Problema ------- con Query PHP 1
G Problema con Query PHP 1
M Problema su update di 3 tabelle PHP 1
T problema con select dinamica con jquery Javascript 0
A Problema checkout carrello php PHP 2
R Problema al server Domini 0
A Problema nel passare la variabile PHP 0
G Problema update di un database PHP 0
S Problema con spazi bianchi HTML e CSS 5

Discussioni simili