Problema CSS!

idkfa46

Utente Attivo
17 Ott 2010
40
0
0
Ciao Ragazzi... ancora una volta chiedo il vostro aiuto per risolvere questo nuovo problema:

La home page del sito che sto creando, viene visualizzata correttamente con Explorer, Chrome e Safari ma se utilizzo Mozilla noto un piccolo errore.

1.jpg
2.jpg

Come potete vedere dalle immagini, il primo screen è stato fatto utilizzando Crome e la visualizzazione è corretta, mentre nel secondo , utilizzando Mozilla, i due riquadri risultano appiccicati !

Ora vi posto il codice che ho utilizzato:

Codice:
<!-- Banners -->  
				<div class="slideGg">
				<div class="btn"><a href="#" class="prev" title="Previous" id="sliderPrev">Previous</a></div>
				<div class="list" style="overflow: hidden;">
					<ul style="width: 636px; margin-left: -212px;" id="sliderWrapper">
                                                <li><a linkindex="86" href="{$script_url}?act=donation" title="donation"><img src="img/banner1.gif" height="80" width="200"></a></li>
                                                <li><a linkindex="87" href="{$script_url}?act=credits" title="credits"><img src="img/banner2.png" height="80" width="200"></a></li>
                                                <li><a linkindex="88" href="{$script_url}?act=referral" title="referral"><img src="img/banner3.png" height="80" width="200"></a></li>
			<li><a linkindex="89" href="{$script_url}?act=mall&cat=item1" title="webshop"><img src="img/banner4.png" height="80" width="200"></a></li>
			<li><a linkindex="90" href="{$script_url}?act=guide" title="features"><img src="img/banner200.png" height="80" width="200"></a></li>
			<li><a linkindex="91" href="{$script_url}?act=vote" title="vote"><img src="img/banner300.png" height="80" width="200"></a></li>

                        					</ul>
				</div>
				<div class="btn"><a href="#" class="next" title="Next" id="sliderNext">Next</a></div>
			</div></p>
                                                 </p>
                            				<div class="slideplayer2">
					<object width="212" height="180"><param name="movie" value="http://www.youtube.com/v/9CUsX4LC1qA&hl=it_IT&fs=1&"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/9CUsX4LC1qA&hl=it_IT&fs=1&" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="230" height="153"></embed></object>
					<object width="212" height="180" border="2"><param name="movie" value="http://www.youtube.com/v/zj-mUj7XWPc?fs=1&amp;hl=it_IT"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/zj-mUj7XWPc?fs=1&amp;hl=it_IT" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="230" height="153" border="2"></embed></object>
					</div>
		
		
		</div>

e il CSS a cui faccio riferimento è:

Codice:
.slideplayer2{ position:relative; z-index:1; margin-top:+0px; width:468px; height:154px; background:url(../img/sprite_main1.png) no-repeat; padding:14px 10px 14px 14px; overflow:hidden;}

Aumentando il valore di margin-top:+0px sono in grado di visualizzare i riquadri separati anche su Mozilla ma con gli altri browser la spaziatura risulta sempre maggiore...

Come posso fare per risolvere questo problema???
Spero di essere stato sufficientemente chiaro.

Grazie, Matteo
 

borgo italia

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
4 Feb 2008
16.042
149
63
PR
www.borgo-italia.it
ciao
due cose:
il tuo codice html si vede un po'incasinato e usa il tag html non codice.
poi prova a togliere <p></p> tra i due div e lavora solo col margin
 

indalo

Utente Attivo
9 Gen 2010
43
0
0
Doppia chiusura

Ha ragione borgo italia.

Oltretutto vedo che il paragrafo lo chiudi due volte senza apertura.

Io non sono un esperto ma forse la cosa nn funzica.

Oltretutto, se non ricordo male, ho letto da qualche parte che margini e padding sono gestiti in modo diverso da Mozzilla e IE.

Ciao.
 

borgo italia

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
4 Feb 2008
16.042
149
63
PR
www.borgo-italia.it
ciao
Oltretutto vedo che il paragrafo lo chiudi due volte senza apertura.
infatti non va bene
....margini e padding sono gestiti in modo diverso da Mozzilla e IE
infatti con ie e ff (non so perche non ho verificato con le ultime versioni) dando a un div largezza, margine e padding l'occupazione di spazio è:
per ie il div occupa uno spazio = alla larghezza con all'interno il pad e mar
per ff il div occupa uno spazio =larg+pad+marg
analogo per l'altezza.
come detto non so se con le nuove versioni questo è superato. prima si doveva "sniffare" il bw e prendere le misure adeguate
 
Discussioni simili
Autore Titolo Forum Risposte Data
S problema con css bootstrap3 HTML e CSS 4
Emix Problema con creazione form css/mobile HTML e CSS 3
F [Javascript] Problema funzione jquery con elementi css esterni Javascript 1
A [WordPress] Problema CSS con diversi browser WordPress 4
S Problema con Form CSS HTML e CSS 1
berry94mf Problema con include e css PHP 1
V Problema Rollover con css HTML e CSS 1
M problema con media query CSS HTML e CSS 1
D Problema collegamento file css con html HTML e CSS 4
S Problema con il css di un font HTML e CSS 2
S Problema tabella datatables a causa dei css HTML e CSS 3
P Problema sovrapposizione di css HTML e CSS 1
A Problema gestione layout con css HTML e CSS 11
Andre7890 Problema CSS in Form Contatti HTML e CSS 7
F problema con sfondo CSS HTML e CSS 2
C Problema con il CSS per il comando text-align HTML e CSS 10
M css html problema con explorer help HTML e CSS 0
G problema con css PHP 9
novello88 Problema stampa CSS [Era: CSS print] HTML e CSS 1
B problema css HTML e CSS 3
B Problema di inserimento "menu con css" in pagina web "con tabelle" HTML e CSS 5
M Problema con css HTML e CSS 3
M problema css con ie8! help HTML e CSS 0
K problema con current css HTML e CSS 0
M Problema CSS e IE HTML e CSS 0
L problema con menù css HTML e CSS 1
T problema con i css ... explorer visualizza male... HTML e CSS 2
I Problema con i CSS su diversi browser HTML e CSS 3
I Problema compatibilità CSS HTML e CSS 1
M [Firefox/CSS] Problema immagine di sfondo centrata HTML e CSS 1
D problema css solo su chrome HTML e CSS 3
F CSS e IE problema HTML e CSS 0
S Problema con CSS IE 7 e XP HTML e CSS 2
O problema menu tendina css HTML e CSS 1
E [Problema] CSS su IE HTML e CSS 6
M Problema CSS nei widget con sfondo sfumato HTML e CSS 0
R Problema con i css in standard mode HTML e CSS 3
N [PHP+HTML+CSS] Problema con un div HTML e CSS 6
R problema con il css dei link HTML e CSS 2
S Piccolo problema con i CSS HTML e CSS 2
I Problema CSS con joomla e phpbb [Era: joomla e phpbb] Joomla 2
G Css, problema margine con explorer HTML e CSS 0
T problema Doctype css e anchor links(credo) HTML e CSS 0
T problema css e firefox HTML e CSS 0
F [CSS] Problema con IE e div fixed HTML e CSS 2
C problema strano css HTML e CSS 5
gladenko CSS e DIV problema di dimensionamento HTML e CSS 3
G Problema coi colori di un menu CSS HTML e CSS 3
R Problema con pop-pu in css HTML e CSS 4
E Problema con CSS con 3 colonne HTML e CSS 5

Discussioni simili