PHP - MAMP - pagina bianca

Palbi

Nuovo Utente
16 Dic 2016
11
0
1
44
Buongiorno a tutti,
sono nuovo del forum, mi chiamo Alberto. Ho un po' di esperienza di programmazione... pascal ... C++ ... tempi dell'università ma sono un po' arrugginito.

In ogni caso vorrei riprendere ed eccomi subito a chiedere aiuto. Grazie molte a chi mi vorrà aiutare.

problema: ho installato sul mac il MAMP, scrivo il semplice prg php di test con echo ed ottengo la pagina bianca. Localhost mi da correttamente l'index. sembra un problema di codice ma non trovo quale.

[16-Dec-2016 09:49:04 Europe/Berlin] PHP Parse error: syntax error, unexpected 'echo' (T_ECHO), expecting identifier (T_STRING) in /Applications/MAMP/htdocs/prima.php on line 14

qualcuno mi aiuterebbe?
grazie mille!


<html>
<head>
<title>la mia prima</title>
<body>
<?php
echo “hello”;
?>
</body>
</html>

P.S: ho messo sul php.ini "ON" per visualizzare gli errori, ma non me li visualizza comunque. nella cartella conf ci sono molte versioni di php, ho cambiato solo il php.ini della 7.0.12 che è quella che impostata nelle impostazioni di mamp.
 

marino51

Utente Attivo
28 Feb 2013
2.918
164
63
Lombardia
premesso che la linea 14 non esiste nel codice che hai postato, quindi solo un'ipotesi,
la riga che precede "echo" non è terminata con il punto e virgola o mancano delle parentesi
 

Palbi

Nuovo Utente
16 Dic 2016
11
0
1
44
ciao, grazie mille ma da sempre lo stesso errore ...

[16-Dec-2016 12:00:07 Europe/Berlin] PHP Parse error: syntax error, unexpected 'echo' (T_ECHO), expecting identifier (T_STRING) in /Applications/MAMP/htdocs/prima.php on line 14

pago birre a volontà se mi aiutate!!!!!

<html>
<head>
<title>la mia prima</title>
<body>
<?php
echo “hello”;
?>
</body>
</head>
</html>
 

borgo italia

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
4 Feb 2008
16.042
146
63
PR
www.borgo-italia.it
ciao
no
HTML:
<html>
<head>
<title>la mia prima</title>
<body>
<?php
echo “hello”;
?>
</body>
</head>
</html>
ma
Codice:
<html>
<head>
<title>la mia prima</title>
</head>
<body>
<?php
echo “hello”;
?>
</body>
</html>
dimenticavo
attento agli apici
PHP:
<?php
echo "hello";
?>
nota la differenza
che editor stai usando? spero NON word
 

Palbi

Nuovo Utente
16 Dic 2016
11
0
1
44
Ciao, scusa il ritardo e grazie ancora.

le virgolette non le avevo proprio considerate, grazie della dritta, non ci sarei mai arrivato.
Purtroppo però non funziona ancora. Sempre pagina bianca e sempre solito errore:

[20-Dec-2016 15:11:22 Europe/Berlin] PHP Parse error: syntax error, unexpected 'echo' (T_ECHO), expecting identifier (T_STRING) in /Applications/MAMP/htdocs/prima.php on line 16

non capisco.

al momento stavo usando un semplice editor, quello nativo del mac. Me ne consiglieresti uno?
 

borgo italia

Super Moderatore
Membro dello Staff
SUPER MOD
MOD
4 Feb 2008
16.042
146
63
PR
www.borgo-italia.it
ciao
scusa, ma quale è la riga 16? ne vedo solo 10
come editor semplice puoi usare blocco note altrimenti digita su google editor php italiano o editor php free, ne trovoi diversi
io ho sempre usato dreamviver, ma costa
 

Palbi

Nuovo Utente
16 Dic 2016
11
0
1
44
OK, ce l'ho fatta.
era solo un problema di codice e di editor probabilmente. Ho usato quello di Xcode e sistemato i dettagli che mi hai indicato.
vicenza centro, hai una birra garantita!