iniziare bcompiler

bambata

Nuovo Utente
5 Feb 2011
3
0
0
salve , vorrei usare bcompiler ma finora senza fortuna
ho wamp con php 5.3.0 e apache 2.2.11 su windows 7 64bit

ho abilitato le estensioni bz2 e bcompiler da php.ini

extension=php_bz2.dll
extension=php_bcompiler.dll


e ho scaricato php_bcompiler.dll da internet ma ricevo un messaggio di errore all'avvio di wamp

php_bcompiler.dll dal sito http://dllcentral.com/php_bcompiler.dll/5.2.5.5/
messaggio :
non è win32 valida

php_bcompiler.dll dal sito http://www.dll-download-it.com/dll-...87&pathid=0
messaggio : dll compiled with module API 20060613
PHP compiled with module API 20090626
these options needs to match

grazie per le risposte
 

bambata

Nuovo Utente
5 Feb 2011
3
0
0
grazie Eliox
http://www.apachefriends.org/f/viewtopic.php?f=16&t=40872
in questa discussione mi sembra di capire che si suggerisce di scaricare il sorgente di bcompiler e di compilarlo , e questa operazione andrebbe rifatta ogni volta che si installa una nuova versione di php ... ma perchè?
possibile che su internet non ci sia la dll php_bcompiler.dll per l'ultima versione di php?
 

netsam

Nuovo Utente
5 Feb 2008
2
0
0
Bcompiler

Qualcuno ha dato risposta alla tua domanda?? E' anche la mia non riesco a trovare il dll giusto.

grazie Eliox
http://www.apachefriends.org/f/viewtopic.php?f=16&t=40872
in questa discussione mi sembra di capire che si suggerisce di scaricare il sorgente di bcompiler e di compilarlo , e questa operazione andrebbe rifatta ogni volta che si installa una nuova versione di php ... ma perchè?
possibile che su internet non ci sia la dll php_bcompiler.dll per l'ultima versione di php?
 

bambata

Nuovo Utente
5 Feb 2011
3
0
0
Qualcuno ha dato risposta alla tua domanda?? E' anche la mia non riesco a trovare il dll giusto.
ciao netsam

non mi sono piu interessato e non ho risolto ma per me la questione è ancora di interesse

ti do le poche indicazioni che ho

su internet ho trovato solo una dll funzionante di bcompiler purltroppo per una vecchia versione di php

non ho cercato di recente ma la cosa migliore è scaricare i sorgenti e compilarli con un po di pasienza

bisogna seguire le indicazioni sul sito in inglese di php bcompiler, se su piattaforma windows anche un tutorial che spiega come compilare una estensione php su windows con msvc++, infatti in questo caso ci sono molti parametri da configurare

per windows le versioni di php che si scaricano su internet sono compilate con VC9 che è la sigla che identifica MS VC++2008
quindi su windows si deve usare necessariamente MS VC++2008, inoltre su ms potrebbe essere richiesto di installare delle librerie aggiuntive ms per il web, in ogni caso devi prima controllare con cosa è compilato il tuo php e questo te lo dice phpinfo() e usare la stessa versione del compilatore, molto probabilmente VC9

su linux non so ma immaggino che sia piu semplice

se riesci a combinare qualcosa fammi sapere

ciao :)
 
Ultima modifica: