Imprecisioni nel linguaggio html delle mia pagina

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
Ciao a tutti sono nuovo di questo forum....
sono un novizio per quanto riguarda l'html e lo sviluppo web...mentre sto imparando questo linguaggio sto realizzando per ora la pagina iniziale del mio sito che è, per rendervi meglio l'idea a sfondo nero e con un logo(che poi sarà cliccabile per entrare nel sito) al centro di 300x230 px......

nella scrittura del codice trovo due errori che non riesco a capire...

quando cerco di centrare perfettamente il mio logo impostando dopo il bgcolor l'attributo topmargin="200", quando aggiorno il codice mi dice che topmargin non e supportato da Opera, Mozilla, Netscape navigator....il codice delle riga "incriminata" è questo:

<body bgcolor="#000000" topmargin="200">

inoltre volendo aggiungere al passaggio del mouse sul logo la scritta ENTER, aggiungo il relativo attributo in questo modo:

<img src="../Immagini/logo.jpg" width="300" height="230" alt="ENTER" title="ENTER"></td>

e anche qui aggiornando poi il codice mi dice che l'attributo title non è supportato da Netscape Navigator 6.0 e Opera in varie versioni....

Volevo capire dove sbaglio dato che è tutto il giorno che ci penso ma non riesco a venirne a capo....

Grazie per l'aiuto e complimenti per il forum!:fonzie:
 

sbobby

Utente Attivo
26 Gen 2006
791
0
0
Roma
Allora per quanto riguarda il title del LINK neanche lo sapevo, ma il fatto che non sia supporatato non credo sia un problema e comunque sia non da errore nel codice...
Il topmargin in-line non è il massimo e potrebbe darti dei problemi...dovresti gestirlo tramite CSS con un margin-top: 200px che è anche molto più elegante e funzionale!!!
 

Kobra

Utente Attivo
27 Giu 2005
72
0
0
Si anch'io consiglio CSS!

Per quanto riguarda "alt" e "title", per le immagini come nel tuo caso credo possa bastare "alt"...nei link invece uso "title" ad esempio...

<a href="galleria.html" title="Galleria">Galleria</a>
 

dead

Utente Attivo
22 Lug 2005
684
0
0
55
Brescia
www.dead.it
Kobra ha scritto:
Si anch'io consiglio CSS!

Per quanto riguarda "alt" e "title", per le immagini come nel tuo caso credo possa bastare "alt"...nei link invece uso "title" ad esempio...

<a href="galleria.html" title="Galleria">Galleria</a>

Per la precisione, anche se spesso i due attributi vengono confusi, title è il titolodell'immagine, alt (ALTernative description), dovrebbe essere una succinta descrizione dell'immagine.

Per esempio title="Giovanni" alt="Primo compleanno di Giovanni"
 

Kobra

Utente Attivo
27 Giu 2005
72
0
0
Ok!

Quindi al fine pratico "alt" va usato solo per le immagini...
 

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
Si le funzioni dell'Alt e title le ho capite...

Ho provato anche a centrare il logo dal punto di vista "Progettazione" di dreamweaver...ed infatti centrando il logo impostando un top margin di 200 px, mi inserisce un body CSS in automatico....

pero nella verifica browser esce che il tag <style> non e supportato da Opera e compagnia bella...

Non riesco a capire perchè escono questi errori di incompatibilità per una banale centratura di un logo sullo sfondo....
 

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
Alla fine il tag <style> l'ho lasciato; alla fine non e supportato solo da Opera 2.0 e 2.1 che sono molto obsoleti come browser...

comunque non ho capito bene nello studio del codice come faccio a rendere il logo cliccabile per poi entrare nel mio sito vero e proprio...

Il mio intento sarebbe creare il logo cliccabile a mo di link verso la Home del mio sito...e con la scritta ENTER ovviamente per spiegare che si clicca sul logo...

Grazie comunque delle dritte!!!
 

dead

Utente Attivo
22 Lug 2005
684
0
0
55
Brescia
www.dead.it
Mancio ha scritto:
Il mio intento sarebbe creare il logo cliccabile a mo di link verso la Home del mio sito...e con la scritta ENTER ovviamente per spiegare che si clicca sul logo...

se ho capito bene quello che vuoi fare...

<a href="http://www.miosito.it" title="ENTER">
<img src="../Immagini/logo.jpg" width="300" height="230" alt="ENTER">
</a>
 

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
Ma dato che per ora sto sviluppando il sito solo in locale e non l'ho ancora trasferito sul server i collegamenti tra le pagine funzionano?? perche dopo aver fatto il collegamento dalla prima pagina nella prova browser provo ad andare nella seconda ma esce sempre "Impossibile visualizzare la pagina"....

Eppure se clicco sull'opzione Apri pagina collegata, viene aperta la seconda pagina correttamente...

Ah quindi l'attributo title va messo dopo il collegamento???

Perchè non avevo capito bene dove inserirlo...ho capito il suo significato ma non avevo molto capito dove inserirlo
 

dead

Utente Attivo
22 Lug 2005
684
0
0
55
Brescia
www.dead.it
Mancio ha scritto:
Ma dato che per ora sto sviluppando il sito solo in locale e non l'ho ancora trasferito sul server i collegamenti tra le pagine funzionano?? perche dopo aver fatto il collegamento dalla prima pagina nella prova browser provo ad andare nella seconda ma esce sempre "Impossibile visualizzare la pagina"....
Vedi se Questa spiegazione ti chiarisce un po' i dubbi.
Mancio ha scritto:
Eppure se clicco sull'opzione Apri pagina collegata, viene aperta la seconda pagina correttamente...

Ah quindi l'attributo title va messo dopo il collegamento???

Perchè non avevo capito bene dove inserirlo...ho capito il suo significato ma non avevo molto capito dove inserirlo

è indifferente inserirlo prima o dopo l'href.
 

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
Ah ecco cosa significava ../!!!!

sono diventato matto tutta la sera ieri per capire cosa fosse...

mi sembra di aver capito quindi il discorso sul percorso relativo e assoluto...adesso provo a smanettarci un pò...

Grazie tante!!!:fonzie:
 

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
anche mettendo il percorso realtivo nei link, nella verifica browser il link mida sempre "Impossibile visualizzare la pagina"...

ho provato anche ad inserirlo assoluto ma nulla da fare....

se vi puo interessare il codice è questo:

<td><a href="/Sviluppo/home.html"><img src="../Immagini/logo.jpg" alt="ENTER TO WEBSITE" width="300" height="230" border="0"></a></td>

li ho capiti i link relativi e assoluti ma evidentemente sbaglio qualcosa...
:dipser:
 

Mancio

Utente Attivo
1 Giu 2006
50
0
0
Pavia
Risolto il problema....
lasciavo il nome della cartella /Sviluppo mentre non era necessaria dato che i due file erano nella stessa cartella...
 
Discussioni simili
Autore Titolo Forum Risposte Data
MarcoGrazia Trovare record nel database partendo da id non sequenziali PHP 4
L PHP motore di ricerca nel sito PHP 1
R [C#] Fare varie operazioni nel proprio account Facebook .NET Framework 0
M Inviare dati nel db dopo risposta alert PHP 0
A recuperare i dati passati nel post PHP 1
S SEOriented è entrato nel forum Presentati al Forum 0
R inserire video nel sito HTML e CSS 15
Cosina Menu fisso copre i titoli quando cliccati nel sommario jQuery Javascript 4
M Stringa con spazi nel menù a tendina PHP 4
A Inserimento dati nel database tramite form + altre operazioni PHP 18
C Store in PHP nel Database PHP 8
A Problema nel passare la variabile PHP 0
M Problema inserimento parole con apostrofo nel db PHP 5
Shyson Inserire placeholder nel campo cerca PHP 5
P Ciao a tutti nel forum Presentati al Forum 0
M Lanciare alert se il codice fiscale è già presente nel db e lasciare la scelta di inserire all'utente PHP 42
M Salvare coordinate Maps nel DB PHP 2
S [PHP] email con inserimento dati nel database PHP 23
F [PHP] Verifica utente presente nel DB PHP 13
U Posizionamento Rack nel locale tecnico ed eventuali accortezze per evitare incendi Reti LAN e Wireless 1
D [WordPress] Link eliminati ancora presenti nel database, è possibile? WordPress 0
M [PHP] Elenco con "classifica" delle informazioni nel db PHP 3
R Ciao a tutti sono felice di entrare nel forum Presentati al Forum 0
MrSab Nel tentativo di reinventarsi in un mondo che cambia.... Presentati al Forum 0
StephenSoftware Flexbox: definizione nel CSS HTML e CSS 4
M [PHP] Problemi su inserimento array nel db PHP 7
L [Javascript]Alternativa al position:sticky nel CSS Javascript 0
M New entry nel forum Presentati al Forum 0
P Jquery event nel foreach php jQuery 3
M [PHP] Stringhe con accento nel POST PHP 3
L PopUp tramite PHP se la mail inserita è già registrata nel database PHP 3
Shyson [PHP] Inserire testo nel codice PHP 2
P Come sponsorizzare nuovi collaboratori nel network marketing sfruttando l'online? Social Media Marketing 2
Cosina Andare a capo nel testo della mail ricevuta dal form php PHP 1
ANDREA20 [PHP] motore di ricerca nel sito PHP 11
G Errore Cannot read property 'childNodes' of undefined per mancanza nodo nel file xml XML 6
F [PHP] Cercare voci uguali nel db e unire alcune variabili PHP 0
F [PHP + MYSQLI] Stampa a video di una tabella nel database PHP 4
T [PHP] Ricerca nel database PHP 2
M [PHP] Vedere tutti i dati presenti nel DB PHP 15
J Prendere dati del database e metterli nel codice php PHP 1
M [VENDO] Banner pubblicitari nel mio blog Vendere e Acquistare pubblicita' online 2
A [PHP] ERRORE QUANDO CAMBIO SLUG NEL CMS e REWRITE PHP 6
M (Vendo negozio online) Vuoi 1 milione € di vendite nel prossimo anno? Compravendita siti e domini 4
Tommy03 Aprire un file .asp nel browser Classic ASP 5
M [PHP] Inserire array nel db PHP 6
baslattuca Messaggi nel tablet Mac e Software 0
A Chiarimento indicazione ISP nel modello AA9 negozio on line E-Commerce 1
W [Javascript] Eseguire script residente nel sistema da html remota Javascript 0
Z [Java] Grassetto assente su font incorporato nel pacchetto jar Java 0

Discussioni simili